Body
Issue/Question
- I don't know what my Net ID or Net ID password is.
Environment
- UTM employee and student logins
Cause
- You may have never used your Net ID or may have forgotten the password to your Net ID account.
Resolution
- Use this guide to find out your Net ID and how to setup or reset your Net ID password
What is my Net ID?
Your Net ID and Password
All students, faculty, and staff at the University of Tennessee have a Net ID and password. Your Net ID permits secure access to a variety of applications and services. Applications that request Net ID authentication vary by campus. For information about which applications require Net ID authentication, contact your local HelpDesk.
Finding Your Net ID
You can look up your Net ID by searching the UT Directory or through Banner Self-Service. Below are instructions for each way.
UT Directory
- Go to https://ds.utk.edu
- Type in your name and select it. (Note: Your NetID should match your UTM Username, please contact the Help Desk at 731-881-7900 to have the NetID updated if it does not match.)
- Your NetID will be listed under your contact card.
Banner Self-Service
- Log in to Banner Self-Service
- Choose the Personal Information menu
- Click on “What is my Net ID?”
Setting Your Net ID Password
Note: You have to set up a password for you Net ID if you have not done so before because it is a separate account from your portal or banner account.
First Time Setup
To set up your Net ID password for the first time, go to https://directory.utk.edu/setup. New passwords will take 15 minutes for your new password to take effect.
Net ID Password Resets
If you can't remember your Net ID password or if your Net ID password has expired, you may be able to reset it using one of the methods below.
Online Password Reset (available if you enabled it when you set your password)
Initial Password Setup (you can only use this method once)
Notes
- If you need further assistance, give the HelpDesk a call at 731-881-7900