Touchnet Password Reset for Authorized Users

Issue/Question

  • An Authorized User is needing to change their password in Touchnet

Environment

  • Windows or Mac OS

Cause

  • An authorized user is needing a password reset. 

Resolution

  • On the Touchnet login page, click on the Authroized User button
  • Type in your email address and then click “Forgot Password”
  • This will send an email to the address provided with a temporary password.
  • After you receive the temporary password, return to the Touchnet page. 
  • Log in and the system will automatically ask to change the password to something you know.

Notes

  • If the authorized user is needing to change the email address used. The student will need to re-add them as a new authorized user. 

Details

Article ID: 133552
Created
Wed 6/23/21 7:40 AM
Modified
Wed 8/9/23 7:43 AM